Форум / Вопросы / ffmpeg не полностью кодирует видео libx264 на linux
пробовал по разному кодировать

открываю ролик просто в браузере
mozilla первые 50% фильма со звуком и картинок, вторые 50% фильма только звук и застывшая картинка
safari iphone первые 50% фильма со звуком и картинок, вторые 50% фильма только звук и застывшая
картинка

открываю ролик в мозилле через флеш плеер uppod — проблем нет
открываю ролик в мозилле через html5 плеер uppod — только 50% ролика картинка. дальше только звук

chrome проблем нет
microsost edge проблем нет
opera проблем нет


ffmpeg -i 1.avi -vcodec libx264 -s 320x180 -movflags +faststart 2.mp4

ffmpeg -i 1.avi -vcodec libx264 -movflags +faststart -crf 20 -vsync 1 -async 1 -acodec aac -vf scale="’w=if(gt(a,16/9),640,-2):h=if(gt(a,16/9),-2,360)’" -ab 128k -maxrate 800k -bufsize 1200k 2.mp4

с другими параметрами пробовал, не помогло

os debian (сервак)
ffmpeg
ffmpeg version 3.3.3–1 Copyright
пробовал старые версии ffmpeg — та же проблема
пробовал другие ролики — та же проблема

перегнал ролик в output.webm — все ок ) в mozilla показывает. (но оформат не катит под apple и др)

поставил на windowd на свой пк ffmpeg попробовал перегнать видео
все ок ) 100% фильма картинка со звуком.


в чем косяк linux ? или что нужно до настроить
achillessСсылка на пост (Смотрели 149)08.08.17 12:36     Ответить
Ваше имя*
 E-mail* (не публикуется)
 
 
Если пишете о проблеме, то приложите, пожалуйста, ссылку на свой плеер отсюда — Плеер: Файл > Код > Ссылка
Вставка кода — [code][/code] дублировать ответы на e-mail
Сообщить об ошибке на сайте
 Uppod © 2008–2017       Контактная информация   /  Соглашение  /  Twitter  /  Facebook
Сообщить об ошибке на сайте
Если ошибка относится к плееру, а не сайту, либо Вы хотите получить ответ на вопрос —
лучше написать на форуме